Edit Mode

Edit mode is used to create custom geometry. The creation process is smooth, quick and effortless. The tools that makeup Edit mode are a fusion of the functions that the users use most often. 

Draw lines

  • From the Object menu choose New Object.
  • From the Edit menu choose Draw line.
  • Click with the cursor anywhere in the work area.
  • Continue clicking to create the desired shape. 
  • Close a continuous line by clicking the cursor on the starting point. 
  • The Minimal number of lines to create a plane shape is 3.
  • Overdraw shapes from the bitmap to add volume to your icons.

Draw primitives

Create mesh geometry right in Edit mode thanks to basic primitives. You can start drawing the primitive anywhere you want by picking the tool in Edit mode and clicking on the scene or objects(make sure you have specific snappings turned on ).

Draw Box

First click on the scene sets the first corner of the cube, second sets diagonal length, and 3rd click sets the height of the box 

box

Draw Torus

The first click on the scene adjusts the circumference of the torus, the second sets its thickness. 

torus

Draw Cone

The first click on the scene adjusts the circumference of the cone, the second sets its height. 

cone

Draw Cylinder

The first click on the scene adjusts the circumference of the cylinder, the second sets its height. 

cylinder

Draw Tube

The first click on the scene adjusts the circumference of the tube, the second sets its thickness and the third its height. 

tube

Draw Polyhedron

You can draw a polyhedron with just one click and by moving the mouse you adjust the size.  

polyhedron

Bevel

The Bevel (also known as chamfer) function bevels your selected points, lines and faces. It's used to make your corners rounded or edges sharper when using a smooth tool. Drag the Bevel jog wheel offset to adjust the size of the bevel and segments to add to the number of segments. There is a little difference between beveling points and lines, and beveling faces.

bevel

How to bevel points and lines

  • Click on the Bevel tool.
  • Select the points or lines you want to Bevel.
  • Use the jog to set parameters. 
  • It behaves like a knife that cuts the line or point off the object. 

How to bevel faces

  • Click on Bevel tool.
  • Select faces you want to Bevel.
  • Use the jog to set parameters. 
  • This is a combination of beveling and extension. 

Make Circle

You can create a circle from points, lines or faces. If you want to extrude a cylinder from existing geometry, create the circle first and then extrude the new geometry.

Extrude

  • In edit mode select Point/Line/Face.
  • Then from the Edit menu choose Extrude.
  • A blue arrow will appear on the extruding component (Point/Line/Face).
  • Drag the blue arrow to extrude the segment (Point/Line/Face).
  • Extrude .swg plane shapes to add volume.

Bridge

  • Select two points, lines or faces. They must not be already connected.They have to be in the same object for the Bridge tool to take effect.
  • Click the Bridge icon in the upper panel or press the v key.
  • The Bridge jog wheel appears. You can adjust the strength, number of segments, twist, and change the continuity of the bridge.
bridge

Slide

You can slide one or multiple lines in the direction of the connected lines at the ends by dragging the handle. Clicking on the handler opens a jog where you can set multiple segments or the precise value of the offset.

slide

Cut

You can use the cut tool to divide the geometry into smaller parts. You can use cut either on the whole geometry of the object or on a selected face only. If you hold shift while using the cut tool, it will snap to the geometry according to the snapping tool settings. After using Cut a jog that includes the following options will appear.

Split

Using split will seperate the geometry from the whole model 

Gap

The gap option defines the distance beteween the two objects after they have been seperated using split.  

Cap

The cap option will determine if the geometry will be open or capped at the borders after using split.  

Multiple cuts

Allows you to use the cut tool indefinetly.  

Collapse

You can select multiple elements of the geometry(points, lines or faces) to collapse them into one point. The Selection will be collapsed into the center of the selection.

collapse

Cap open boundaries

Is a tool that is used to close open boundaries left after deleting a face or if an imported model is missing faces. 

close

Normals settings

Smooth Threshold

Edges with an angle smaller than the smooth threshold will appear smooth. Edges with an angle larger than the smooth threshold will appear sharp. Use this if you want your object to look smooth without modifying the geometry.

Flip Normals 

Front of the face is now it’s back and vice-versa If “double-sided” is turned off on your material, the faces are invisible from the back.

Unify Normals

Intelligently flips normals so they all point “outwards”. Only useful on manifold meshes.